Link aggregation on Solaris QFS clients
the switch
The HSM server are connected to switch 13 or switch 14.
In order to find the right ports do a
enable
show fdb-table learned 00:MA:CA:DD:RE:SS
The two NICs of one server must be connected on the same FS500.
Usually it is a odd port and the next even port.
In order to learn which LAGs have been configured already do a
show lag all
Create a new LAG (E.g.: LAG 5 named HSMxyz containing port 1/23 1/24):
configure
lag 5
add-port 1/23
add-port 1/24
name HSMxyz
mtu 9044
lacp
exit
exit
file
copy running-config startup-config
exit
logout
the server
All this should be done via the serial console and/or a connection NOT using the myricom driver
- stop the nfs/server
svcadm disable nfs/server
- Download myricom GDLv3 driver (from here), or directly by
wget https://www.myricom.com/pub/Myri10GE/gldv3/binary/S10u9_and_S11/myri10ge-solaris-amd64.1.4.5.gldv3.07.11.2012.tgz
, then run these commands
tar -xf myri10ge-solaris-amd64.1.4.5.gldv3.07.11.2012.tar
cd myri10ge-solaris-amd64.1.4.5.gldv3.07.11.2012
for i in 0 1; do ifconfig myri10ge$i down; ifconfig myri10ge$i unplumb; done
rem_drv myri10ge
cp myri10ge /kernel/drv/amd64/
./mge
-
dladm show-link
should now show both myricom devices again
- create aggregation
dladm create-aggr -d myri10ge0 -d myri10ge1 1
- and bring device up, please use the correct IP address here:
ifconfig aggr1 plumb 10.20.21.X up
- get rid off old hostname files and create a new one - again replace X with the correct number
rm -f /etc/hostname.myri10ge0 /etc/hostname.myri10ge1
echo "x4140-X-1 netmask + broadcast + up" > /etc/hostname.aggr1
- reboot machine
sync; init 6
- then enable nfs again:
svcadm enable nfs/server
--
CarstenAulbert - 08 Feb 2013